NI的GPIB-USB-HS与METROLAB的PT2025旧版本可通讯,与新版本不能通

杨静No1 1年前 178次点击 来自 问答

先后购买的METROLAB的PT2025,均有IEEE488通讯界面,先前的产品(IO类型是2204C)可以与NI的GPIB-USB-HS/B通讯,后买的(IO类型是2204D)不能与之通讯,考虑到2204D的版本较新,可能需要升级488的驱动,请问有没有这种可能?如果有这个可能,那么NI是否提供最新的驱动?如果还有其他可能,请帮我们分析。通讯的问题已经困扰我们两周多了,希望能尽快解决。

  NI中文技术论坛

12 条回复
Charles.Tac 1年前

Hi jwdz,

 

正如您所猜想的,NI-Spy是NI-VISA自带的调试工具,完全免费。用来抓取VISA通信的数据包,分析仪器通信命令与协议等相当方便。

 

可谓居家旅行必备!哈哈!

 

非常高兴能在你的主页上放上介绍NI-Spy的小文章,这也是推广这一工具的一个方法,我抽空整理一下。然后私信或者发你邮箱吧!

 

再次感谢你对LabVIEW以及Instrument Contrrol领域的不懈支持!

 

 

 

 

jwdz 1年前
Charles.Tac 已写:

Hi jwdz,

 

正如您所猜想的,NI-Spy是NI-VISA自带的调试工具,完全免费。用来抓取VISA通信的数据包,分析仪器通信命令与协议等相当方便。

 

可谓居家旅行必备!哈哈!

 

非常高兴能在你的主页上放上介绍NI-Spy的小文章,这也是推广这一工具的一个方法,我抽空整理一下。然后私信或者发你邮箱吧!

 

再次感谢你对LabVIEW以及Instrument Contrrol领域的不懈支持!

 

 

 

 

期待你的佳作诞生!

" 一天到晚游泳的鱼"

labview[@263.net](http://www.labview.help/user/263.net)

我的个人网站:LabVIEW——北方客栈 http://www.labview365.com
欢迎加入《LabVIEW编程思想》组——http://decibel.ni.com/content/groups/thinking-in-labview
杨静No1 1年前

下载安装了488.2,还是搜不到设备,NI-Spy显示的错误如附件中图片所示,请高手指教。

 

Charles.Tac 1年前

请问您有没有安装最新的NI-488.2安装包(link)?另外建议您在通信的时候使用NI-Spy查看一下是哪里出了error。

杨静No1 1年前

谢谢,可能是没有安装最新驱动的原因吧,正在下载

jwdz 1年前
Charles.Tac 已写:

请问您有没有安装最新的NI-488.2安装包(link)?另外建议您在通信的时候使用NI-Spy查看一下是哪里出了error。


尊敬Charles.Tac先生:

 

看到你多次提到NI-Spy,我们没有使用过,对此了解甚少。

 

你可否写一些关于什么是NI-Spy?它是免费的吗?除了仪器控制还可以应用在那些方面?如何使用NI-Spy,以及一些应用实例。我可以在个人主页上为NI-Spy做个专栏。

 

祝你好运!

" 一天到晚游泳的鱼"

labview[@263.net](http://www.labview.help/user/263.net)

我的个人网站:LabVIEW——北方客栈 http://www.labview365.com
欢迎加入《LabVIEW编程思想》组——http://decibel.ni.com/content/groups/thinking-in-labview

©2017 Powered by LabVIEW社区 - To Be Better
Any questions please contact us:confidante@labview.help